0 votes
asked in MicroStream for Java by (170 points)
edited by
My comment was too early. When I set the root or call start with an initialized root, it still doesn't load. It just uses the initialized root to work with. When I set the root via the start method I get an exception:

Caused by: one.microstream.persistence.exceptions.PersistenceException: Missing runtime type for required type handler for type: de.b4.docster.model.Archive

I put nearly the same code into code without Quarkus which works fine.
related to an answer for: MicroStream and Quarkus

1 Answer

0 votes
answered by (3.9k points)
selected by
Best answer


This looks like a class loader related problem. It is possible to specify the class loader Microstream should use.

See https://manual.docs.microstream.one/data-store/customizing/custom-class-loader.

Unfortunately, I am no Quarkus expert, therefore I can give you hints regarding Quarkus.
But judging from the website, the technology uses some kind of hot code replacement. This may be very problematic with Microstream as we analyse classes and deriver metadata to handle instances on the first time Microstream encounters a class.

Best regards

commented by (170 points)
Now it works. Thanks again.
Notes: Every question must be a separate forum post. Headline: Formulate your question shortly and precisely. Thank you!
Powered by Question2Answer